import re
regex = re.compile(r"(?s)Block (\d+) start.+Block \1 end", flags=re.MULTILINE)
test_str = ("Block 1 start\n"
"Line 1 in Block 1\n"
"Line 2 in Block 1\n"
"Block 1 end\n\n"
"Block 2 start\n"
"Line 1 in Block 2\n\n"
"Block 3 start\n"
"Line 1 in Block 3\n"
"Block 3 end")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")