#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^/(?!scripts/(?!my_app/)).*"
Local $sString = "/scripts/my_app/" & @CRLF & _
"/scripts/my_app/xxxx.sh" & @CRLF & _
"/scripts/my_app/yyyyy/xxxz.sh" & @CRLF & _
"" & @CRLF & _
"/scripts/" & @CRLF & _
"/scripts/another_string/xxxx.sh" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"/xxxx/yyyy/zzzzz/qqqq.sh" & @CRLF & _
"/aaaa/bbbb/ccc.sh" & @CRLF & _
"" & @CRLF & _
"/scripts/my_app_OLD/ "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")