# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^/(?!scripts/(?!my_app/)).*"
test_str = ("/scripts/my_app/\n"
"/scripts/my_app/xxxx.sh\n"
"/scripts/my_app/yyyyy/xxxz.sh\n\n"
"/scripts/\n"
"/scripts/another_string/xxxx.sh\n\n\n"
"/xxxx/yyyy/zzzzz/qqqq.sh\n"
"/aaaa/bbbb/ccc.sh\n\n"
"/scripts/my_app_OLD/ ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.