using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^/(?!scripts/(?!my_app/)).*";
string input = @"/scripts/my_app/
/scripts/my_app/xxxx.sh
/scripts/my_app/yyyyy/xxxz.sh
/scripts/
/scripts/another_string/xxxx.sh
/xxxx/yyyy/zzzzz/qqqq.sh
/aaaa/bbbb/ccc.sh
/scripts/my_app_OLD/ ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}