use strict;
my $str = '/scripts/my_app/
/scripts/my_app/xxxx.sh
/scripts/my_app/yyyyy/xxxz.sh
/scripts/
/scripts/another_string/xxxx.sh
/xxxx/yyyy/zzzzz/qqqq.sh
/aaaa/bbbb/ccc.sh
/scripts/my_app_OLD/ ';
my $regex = qr`^/(?!scripts/(?!my_app/)).*`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}