const regex = new RegExp('^/(?!scripts/(?!my_app/)).*', 'gm')
const str = `/scripts/my_app/
/scripts/my_app/xxxx.sh
/scripts/my_app/yyyyy/xxxz.sh
/scripts/
/scripts/another_string/xxxx.sh
/xxxx/yyyy/zzzzz/qqqq.sh
/aaaa/bbbb/ccc.sh
/scripts/my_app_OLD/ `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}