#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!0{3})\d{5}(?:-?\d{4})?$"
Local $sString = "12345" & @CRLF & _
"12345-6789" & @CRLF & _
"123456789" & @CRLF & _
"00000" & @CRLF & _
"00000-0000" & @CRLF & _
"000000000" & @CRLF & _
"00000" & @CRLF & _
"00012-3214" & @CRLF & _
"00139" & @CRLF & _
"00136-3654" & @CRLF & _
"00336-69856" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")