import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!0{3})\\d{5}(?:-?\\d{4})?$";
final String string = "12345\n"
+ "12345-6789\n"
+ "123456789\n"
+ "00000\n"
+ "00000-0000\n"
+ "000000000\n"
+ "00000\n"
+ "00012-3214\n"
+ "00139\n"
+ "00136-3654\n"
+ "00336-69856\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}