re = /^(?!0{3})\d{5}(?:-?\d{4})?$/m
str = '12345
12345-6789
123456789
00000
00000-0000
000000000
00000
00012-3214
00139
00136-3654
00336-69856
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end