using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!0{3})\d{5}(?:-?\d{4})?$";
string input = @"12345
12345-6789
123456789
00000
00000-0000
000000000
00000
00012-3214
00139
00136-3654
00336-69856
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}