const regex = /^(?!0{3})\d{5}(?:-?\d{4})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!0{3})\\d{5}(?:-?\\d{4})?$', 'gm')
const str = `12345
12345-6789
123456789
00000
00000-0000
000000000
00000
00012-3214
00139
00136-3654
00336-69856
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}