#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[1-9][0-9]*(?:\.[0-9]+)?\$?$"
Local $sString = "t1est" & @CRLF & _
"230.01" & @CRLF & _
"foo" & @CRLF & _
"bar" & @CRLF & _
"304958$" & @CRLF & _
"bar" & @CRLF & _
"534534$23"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")