import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[1-9][0-9]*(?:\\.[0-9]+)?\\$?$";
final String string = "t1est\n"
+ "230.01\n"
+ "foo\n"
+ "bar\n"
+ "304958$\n"
+ "bar\n"
+ "534534$23";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}