$re = '/^[1-9][0-9]*(?:\.[0-9]+)?\$?$/m';
$str = 't1est
230.01
foo
bar
304958$
bar
534534$23';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);