package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[1-9][0-9]*(?:\.[0-9]+)?\$?$`)
var str = `t1est
230.01
foo
bar
304958$
bar
534534$23`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}