using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.(cgi|asp|aspx|cfg|dll|exe|jsp|mdb|sql|ini|rar)$";
string input = @"foo/test.html
foo/bar.cgi
foo/image.png";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}