// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\.(cgi|asp|aspx|cfg|dll|exe|jsp|mdb|sql|ini|rar)$").unwrap();
let string = "foo/test.html
foo/bar.cgi
foo/image.png";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}