$re = '/\.(cgi|asp|aspx|cfg|dll|exe|jsp|mdb|sql|ini|rar)$/m';
$str = 'foo/test.html
foo/bar.cgi
foo/image.png';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);