re = /\.(cgi|asp|aspx|cfg|dll|exe|jsp|mdb|sql|ini|rar)$/m
str = 'foo/test.html
foo/bar.cgi
foo/image.png'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end