package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.(cgi|asp|aspx|cfg|dll|exe|jsp|mdb|sql|ini|rar)$`)
var str = `foo/test.html
foo/bar.cgi
foo/image.png`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}