#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d+(?:[.,]\d+)?)"
Local $sString = "Есть стринга типа 'asda12312.234234ertert,34534'. Нужно достать из неё только цифры ипервую точку или запятую." & @CRLF & _
"'asda12312.234234ertert,34534' => '12312.23423434534'" & @CRLF & _
"'asda12312,234234ertert,34534' => '12312,23423434534'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")