import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+(?:[.,]\\d+)?)";
final String string = "Есть стринга типа 'asda12312.234234ertert,34534'. Нужно достать из неё только цифры ипервую точку или запятую.\n"
+ "'asda12312.234234ertert,34534' => '12312.23423434534'\n"
+ "'asda12312,234234ertert,34534' => '12312,23423434534'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}