$re = '/(\d+(?:[.,]\d+)?)/m';
$str = 'Есть стринга типа \'asda12312.234234ertert,34534\'. Нужно достать из неё только цифры ипервую точку или запятую.
\'asda12312.234234ertert,34534\' => \'12312.23423434534\'
\'asda12312,234234ertert,34534\' => \'12312,23423434534\'';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);