using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+(?:[.,]\d+)?)";
string input = @"Есть стринга типа 'asda12312.234234ertert,34534'. Нужно достать из неё только цифры ипервую точку или запятую.
'asda12312.234234ertert,34534' => '12312.23423434534'
'asda12312,234234ertert,34534' => '12312,23423434534'";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}