import re
regex = re.compile(r"(\d+(?:[.,]\d+)?)", flags=re.MULTILINE)
test_str = ("Есть стринга типа 'asda12312.234234ertert,34534'. Нужно достать из неё только цифры ипервую точку или запятую.\n"
"'asda12312.234234ertert,34534' => '12312.23423434534'\n"
"'asda12312,234234ertert,34534' => '12312,23423434534'")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")