# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\w(?=(?:\W*\w){6})/+/gm;t' <<< "HFGR56 GGKDJ JGGHG JGJGIR"