$re = '/\w(?=(?:\W*\w){6})/m';
$str = 'HFGR56 GGKDJ JGGHG JGJGIR';
$subst = "+";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;