re = /\w(?=(?:\W*\w){6})/m
str = 'HFGR56 GGKDJ JGGHG JGJGIR'
subst = '+'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result