import Foundation
let pattern = #"\w(?=(?:\W*\w){6})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"HFGR56 GGKDJ JGGHG JGJGIR"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"+"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)