#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\w(?=(?:\W*\w){6})"
Local $sString = "HFGR56 GGKDJ JGGHG JGJGIR"
Local $sSubst = "+"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)