import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?(?:\\b|_)Infrastructure Change ID(?:\\b|_).*?(?:\\b|_)CRQ000000030315(?:\\b|_).*?$";
final String string = "('Infrastructure Change ID' IN (\"CRQ000000030315\", \"CRQ000000030316\"))";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}