import Foundation
let pattern = #"^.*?(?:\b|_)Infrastructure Change ID(?:\b|_).*?(?:\b|_)CRQ000000030315(?:\b|_).*?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"('Infrastructure Change ID' IN ("CRQ000000030315", "CRQ000000030316"))"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}