$re = '/^.*?(?:\b|_)Infrastructure Change ID(?:\b|_).*?(?:\b|_)CRQ000000030315(?:\b|_).*?$/m';
$str = '(\'Infrastructure Change ID\' IN ("CRQ000000030315", "CRQ000000030316"))';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);