re = /^.*?(?:\b|_)Infrastructure Change ID(?:\b|_).*?(?:\b|_)CRQ000000030315(?:\b|_).*?$/m
str = '(\'Infrastructure Change ID\' IN ("CRQ000000030315", "CRQ000000030316"))'
# Print the match result
str.match(re) do |match|
puts match.to_s
end