const regex = /^[\d\.\s]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\d\\.\\s]+', 'gm')
const str = `3.1. Задание 1.jpg
3.2 Задание 1. Расчет ИМТ.docx
4. Задание 2.docx
6. Чек-лист.txt`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}