$re = '/^[\d\.\s]+/m';
$str = '3.1. Задание 1.jpg
3.2 Задание 1. Расчет ИМТ.docx
4. Задание 2.docx
6. Чек-лист.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);