using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @";\K(\s*.*?)(\s*\S+)$";
string substitution = @"\2\1";
string input = @"CFq3kHZMEqb.txt; ""CFq3kHZMEqb.jpg"" ""CFq3kHZMEqb-MI2.jpg""
CFwvdIcAji2.txt; ""CFwvdIcAji2-MI2.jpg"" ""CFwvdIcAji2.jpg"" dsgfgdfg";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}