const regex = /;\K(\s*.*?)(\s*\S+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(';\\K(\\s*.*?)(\\s*\\S+)$', 'gm')
const str = `CFq3kHZMEqb.txt; "CFq3kHZMEqb.jpg" "CFq3kHZMEqb-MI2.jpg"
CFwvdIcAji2.txt; "CFwvdIcAji2-MI2.jpg" "CFwvdIcAji2.jpg" dsgfgdfg`;
const subst = `\2\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);