re = /;\K(\s*.*?)(\s*\S+)$/m
str = 'CFq3kHZMEqb.txt; "CFq3kHZMEqb.jpg" "CFq3kHZMEqb-MI2.jpg"
CFwvdIcAji2.txt; "CFwvdIcAji2-MI2.jpg" "CFwvdIcAji2.jpg" dsgfgdfg'
subst = '\\2\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result