import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ";\\K(\\s*.*?)(\\s*\\S+)$";
final String string = "CFq3kHZMEqb.txt; \"CFq3kHZMEqb.jpg\" \"CFq3kHZMEqb-MI2.jpg\" \n"
+ "CFwvdIcAji2.txt; \"CFwvdIcAji2-MI2.jpg\" \"CFwvdIcAji2.jpg\" dsgfgdfg";
final String subst = "\\2\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}