const regex = /^(Hornet ?|Valiant ?)?+(.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(Hornet ?|Valiant ?)?+(.+)', 'gm')
const str = `Mazda RX4
Mazda RX4 Wag
Datsun 710
Hornet 4 Drive
Hornet Sportabout
Valiant`;
const subst = `$1*$2*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);