use strict;
my $str = 'Mazda RX4
Mazda RX4 Wag
Datsun 710
Hornet 4 Drive
Hornet Sportabout
Valiant';
my $regex = qr/^(Hornet ?|Valiant ?)?+(.+)/mp;
my $subst = '$1*$2*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";