re = /^(Hornet ?|Valiant ?)?+(.+)/m
str = 'Mazda RX4
Mazda RX4 Wag
Datsun 710
Hornet 4 Drive
Hornet Sportabout
Valiant'
subst = '$1*$2*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result