$re = '/^(Hornet ?|Valiant ?)?+(.+)/m';
$str = 'Mazda RX4
Mazda RX4 Wag
Datsun 710
Hornet 4 Drive
Hornet Sportabout
Valiant';
$subst = "$1*$2*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;