#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\s*(<li.*>)?\s*(<p.*>.*<\/p>)\s*(<\/li>)?"
Local $sString = "<ul>" & @CRLF & _
" <li>1</li>" & @CRLF & _
" <li><p>2</p></li>" & @CRLF & _
" <li>" & @CRLF & _
" <ul>" & @CRLF & _
" <li><p>3</p></li>" & @CRLF & _
" </ul>" & @CRLF & _
" </li>" & @CRLF & _
"</ul>" & @CRLF & _
"" & @CRLF & _
"<ul>" & @CRLF & _
" <li>" & @CRLF & _
" <ul>" & @CRLF & _
" <li></li>" & @CRLF & _
" <p>4</p>" & @CRLF & _
" </ul>" & @CRLF & _
" </li>" & @CRLF & _
"</ul>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")