// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s*(<li.*>)?\s*(<p.*>.*<\/p>)\s*(<\/li>)?").unwrap();
let string = "<ul>
<li>1</li>
<li><p>2</p></li>
<li>
<ul>
<li><p>3</p></li>
</ul>
</li>
</ul>
<ul>
<li>
<ul>
<li></li>
<p>4</p>
</ul>
</li>
</ul>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}