# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\s*(<li.*>)?\s*(<p.*>.*<\/p>)\s*(<\/li>)?"
test_str = ("<ul>\n"
" <li>1</li>\n"
" <li><p>2</p></li>\n"
" <li>\n"
" <ul>\n"
" <li><p>3</p></li>\n"
" </ul>\n"
" </li>\n"
"</ul>\n\n"
"<ul>\n"
" <li>\n"
" <ul>\n"
" <li></li>\n"
" <p>4</p>\n"
" </ul>\n"
" </li>\n"
"</ul>\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.