re = /\s*(<li.*>)?\s*(<p.*>.*<\/p>)\s*(<\/li>)?/m
str = '<ul>
<li>1</li>
<li><p>2</p></li>
<li>
<ul>
<li><p>3</p></li>
</ul>
</li>
</ul>
<ul>
<li>
<ul>
<li></li>
<p>4</p>
</ul>
</li>
</ul>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end