const regex = /\s*(<li.*>)?\s*(<p.*>.*<\/p>)\s*(<\/li>)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*(<li.*>)?\\s*(<p.*>.*<\\\/p>)\\s*(<\\\/li>)?', 'gm')
const str = `<ul>
<li>1</li>
<li><p>2</p></li>
<li>
<ul>
<li><p>3</p></li>
</ul>
</li>
</ul>
<ul>
<li>
<ul>
<li></li>
<p>4</p>
</ul>
</li>
</ul>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}