#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=^FS-[a-zA-Z0-9]*)[a-z]|[\p{Zs}\ta-z](?=[a-zA-Z0-9\p{Zs}\t]*$)"
Local $sString = "(S)FSK-69/23/GFK/ 1 2 " & @CRLF & _
"(S)FSK-69/23/GFK/12" & @CRLF & _
"" & @CRLF & _
"FS-4444g/23g/F/1g1" & @CRLF & _
"FS-4444/23g/F/11"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)